
QUICK AND SIMPLE INTERNET RADIO STREAMING  (Oct. 25, 2004) 
 
Read the directions through entirely before starting. Things you will need: 

1. A Mac running System 10.3, with a dedicated IP address. Log on with administrative privileges. 
2. Darwin Streaming Server 5.0.1 (DSS), download from 

http://developer.apple.com/darwin/projects/streaming/ 
Note: The download link is at the bottom, under Binary Releases. Click on “server” for 
OSX. You need an Apple ID (free). DSS is equivalent to QuickTime Streaming Server 
5.0.3 for Mac OSX Server 10.3 
Download the Darwin Streaming Server’s Administrator’s guide while you are here. 
DSS will try to install after downloading, cancel this until you are ready to install. 

3. QuickTime Broadcaster (QTB), download from 
http://www.apple.com/quicktime/products/broadcaster/ 
 QTB will try to install after downloading, cancel this until you are ready to install. 

4. QuickTime 6.5 Pro (QT) or better ($30), from http://www.apple.com/quicktime/download 
5. An FM tuner or radio with analog headphone output or line output. (or a mixing board with the line 

output of your audio source) 
6. A USB audio input interface, such as iMic ($40) from 

http://griffintechnology.com/products/imic/index.html 
Or the UA-20 from http://www.edirol.com/products/audio.html 

7. A stereo audio cable to connect from the tuner to the USB audio interface, usually stereo (TRS) 
male 1/8" to stereo (TRS) male 1/4". 

 
Three software applications are needed to make this work: QTSS (DSS), QTB, and a web server. 
Apache, a web server, is included with System 10.3. The three applications can all be used on one 
computer, or can be distributed in any combination over two or three computers. If you are using OSX 
Server, the instructions are different, but this may give you some help if you get stuck.  
 
To make this installation as simple as possible, we will assume you have access to a web server on 
another computer. We will install QTSS and QTB on our computer, and serve the web pages on another. 
After each step, test the successful completion of that step. If the step does not test successfully, debug 
before going further! 
 

A. SET UP YOUR NETWORK 
1. Log on as an administrator. Set up your System Preferences>Network>TCP/IP for a dedicated IP 

address. The following is fictitious, DO NOT USE IT! Get help from your network technicians to 
enter your own numbers. 

 

 
 

 



 
2. For now, in System Preferences>Sharing>Services, make sure all services are off, and firewall is off. 
3. Log onto the internet with your web browser, to ensure your IP connection works. 
 

B. SET UP QUICKTIME STREAMING SERVER 
1. DSS should have downloaded on your desktop as DarwinStreamingSrvr-5.x.OSX.dmg, and 

automatically expanded to a disk image called DarwinStreamingSrvr-5.xOSX, with 
DarwinStreamingServer.pkg inside it. We previously stopped the auto-install, now start it by 
clicking on the .pkg. Install to your boot drive. It should install to your Applications folder. In your 
Applications folder, find QuickTime Streaming Server and click on it. 

2. This should automatically open your web browser to 
http://127.0.0.1:1220/parse_xml.cgi?filename=setup_assistant2.html and you should see the 
following: 

 
 

2. Enter your New User Name, say radio2, and your New Password, say password2. Click Set 
Password. 

3. Enter the same password for the MP3 broadcast password for now, click Next. 
4. Forget about Setup Assistant Secure Administration for now, and click Next. 
5. For Media Folder, select the default /Library/QuickTimeStreaming/Movies, and click Next 
6.  Enable streaming over Port 80, and click Finish. 
7. You should now see the main web admin interface for DSS, at 

http://127.0.0.1:1220/parse_xml.cgi. Make sure that "server is running" and your dedicated IP are 
showing at the top. 

8. Click on Port Settings. Make sure Streaming on Port 80 is enabled. You may have to select this 
again, and save changes, and the screen may not refresh until after the next step. 

9. Reboot the computer. 
 
You should now have two different username/password combinations: for the computer admin, and for 
QTSS. Use the appropriate password in the appropriate situation, you cannot interchange them. Now, 
reboot the computer, and we'll check that QTSS is running. 
 

10. Go to another computer on the network, and type http://yourIP:1220, where “yourIP” is your 
dedicated IP (a number with three periods in it) 

11. You should see this: 

 
 

12. Log in with your QTSS User Name and Password, i.e., radio2 and password2, you will then reach 
the main web admin interface. Confirm that QTSS is running on the correct IP, and on Port 80. 

13. Test that streaming is working. On another computer, in QuickTime Player, go to File>Open URL 
in New Player, and type rtsp://yourIP/sample_100kbit.mov. The movie should stream and play. 
This is a test movie installed on your server, in the directory 



Macintosh HD/Library/QuickTimeStreaming/Movies. All movies you wish to stream need to go in 
here. 

 
C. SET UP YOUR AUDIO INPUT 

1. Tune your FM station on your radio, try to get a clean signal. Connect the line output or 
headphone output to your USB audio converter. If you have a VU meter, or audio controls, don't 
make the signal too hot, stay at about 50%-75% of "red", or at a comfortable headphone listening 
level. Too hot a signal will increase compression artifacts. 

2. Check that the computer is recognizing your audio input. Go to System 
Preferences>Sound>Input. Make sure your USB input device is showing and selected. If you are 
able to, as with the iMic, set your input volume so it is about half-way to three-quarter of max, but 
does not reach max. 

3. You may replace the FM tuner with an audio mixer, or any audio output with a line out or 
headphone level output. If you are just narrating, you may use a USB mic as a USB input device. 

 
D. SETTING UP QUICKTIME BROADCASTER 
(on the same computer as QTSS, or on another) 

1. Broadcaster should have downloaded as QuickTimeBroadcaster.dmg. When you double-click on 
it, the disk image will mount, with QuickTimeBroadcaster.pkg in it. Click on this to install QTB on 
your boot drive, in the Applications folder. 

2. After installation, open QTB and click on “Show Details.” Go to the Network pane. Ignore "Preset" 
(Leave on Custom). For "Transmission" select Automatic Unicast (Announce), for "Host Name" 
type in the IP of your QTSS, i.e. 136.244.12.2, For "File" type "station1" without the quotes, for 
Username and Password type your QTSS Broadcast username and password, radio2 and 
password2. Leave everything else blank. 

3. Go to the Video pane, As there is no video input, everything should be grayed out. Go to the 
Audio pane. Check "Enable Audio Stream". Select the preset Modem-Music. Make sure your 
USB audio device is showing and selected, Leave the gain at mid-point, for now. 

4. We'll tweak the MPEG-4 Audio settings. Click "Options". Select a bit rate of 32 kbits/sec, an 
encoder quality of Best (keep at Better for older computers), and an output sample rate of 22.05 
KHz. Leave at Mono 16 bit. Click on Broadcast. The statistics under the broadcast window should 
indicate activity. The rtsp URL at the bottom  should be rtsp://yourIP/station1.sdp 

5. Test the live audio stream. On another computer, in QuickTime Player, go to File>Open URL in 
New Player, and type rtsp://yourIP/station1.sdp The audio should buffer for a few seconds, and 
then play. Now adjust the audio gain slider in the Audio pane of QTB so the audio averages at 
about 50% loudness in QuickTime Player. There may be a long delay between your changes and 
the results, so be patient.  

 
E. SETTING UP YOUR WEB PAGE 

 
1. Open QuickTime Player Pro on another computer, to your live audio stream, by typing in 

File>Open URL rtsp://yourIP/station1.sdp. 
2. Make a reference movie. Go to Save As, and save as station1.mov, to your desktop, making the 

movie self-contained. Quit QT Player. 
3. Click on the movie on your desktop, station1.mov, to ensure the audio stream still plays. Go to 

Movie>Get Movie Properties>Movie>AutoPlay, and make sure AutoPlay is enabled. 
4. Go to this web page: http://video.conncoll.edu/radio_live.html. (This page will not work until you 

modify it to your own settings). 
5. Click and hold the mouse down on the speaker icon (this is ours, you may BORROW it for testing 

until you make your own), and save to your desktop as speaker_button1.mov, you can only do 
this if you have QuickTime Player Pro installed. 

6. Go to view the page source in your browser, copy and paste the code to a plain text editor, or to 
your HTML editor (you may have to do some cleaning up). This page contains the "heart" of the 
code. 

7. Save the HTML file to your desktop, as station1.html. Make sure the movies 
speaker_button1.mov and station1.mov are still on your desktop. Open station1.html with your 
web browser, and click on the speaker icon. The audio file should stream. 

8. Upload the three files to your web server, in the same folder. You may have to change the URL 
for the file station1.mov to an absolute URL. 

9. Once things work, you can make them pretty! 
10. Check you CPU utilization with Process Viewer and CPU Monitor to ensure you are not “maxed 

out” 



 
THIS IS A DRAFT AND MAY CONTAIN SOME ERRORS. IT IS POSTED WITH THE INTENT OF 
HELPING ANYONE THAT MIGHT NEED TO GET STARTED RIGHT AWAY. 
 
IF THERE ARE ANY ERRORS, PLEASE EMAL ffu@conncoll.edu 
Frank Fulchiero, Digital Media Specialist, Instructional Design Group, Connecticut College 
 
NOTES-The above is designed to enable HTTP audio streaming over Port 80, to get you started. To 
stream UDP, you will need your network administrators to open additional ports. This is a guide for a 
simple setup to get you going. You'll need to do more research and work to develop it further, this is 
beyond the scope of these instructions. 
 
Ensure you have enough bandwidth to stream, co-ordinate with your network technicians. 
Webcasting of copyrighted music needs to meet copyright law guidelines, see 
http://collegebroadcasters.org/ 
Check out our station at http://video.conncoll.edu/wcni/wcni_live.html 
 

F. “ADVANCED” OPTIONS 
 
Make your own poster movie. 
 

1. This is to make your own speaker_button1.mov for your web page. 
2. Open Photoshop to a new document, 30 x 30 pixels, 72 dpi, RGB color. 
3. Make your graphic, flatten it, and save it as a tiff. 
4. In QuickTime Player Pro, open the tiff (File>Open Movie in New Player>Convert) 
5. Go to File>Export>Movie to QuickTime Movie, in Options, select Photo JPEG, do not optimize for 

streaming, do not Prepare for Internet Streaming, set frame rate to 1, and save as 
speaker_button1.mov. Open this movie with QuickTime Player Pro, and make sure that Auto-Play 
is disabled (Found in Movie>Get Movie Properties). 

6. If your image is different from 30x30 pixels, make sure you change the html code to reflect this. 
 
Run Multiple copies of QT Broadcaster 
 

1. Close all your copies of QTB. 
2. Open your Applications folder, and set it to view as list. 
3. Select your copy of QTB. Go to Edit>Copy. Then go to Edit>Paste. 
4. You can make several copies of QTB, then give each one a different number: 

 

 
 

5. Open each copy, one at a time. Select your settings, then go to File>Save Broadcast Settings As, 
and give each setting a simple one word name. Make sure each setting’s File Name is different in 
the Network tab, as this is the name of the sdp file Broadcaster creates in the  
Macintosh HD/Library/QuickTimeStreaming/Movies folder. Then click the Broadcast button, go on 
to the next copy of QTB, and repeat the above procedure. Make sure that the title bar of each 
copy of QTB shows the name of the settings. If you quit that version of QTB, next time you want 
to use those settings, open that QTB, go to File>Open Broadcast Settings, and load your 
settings. 
 



6. Multiple copies of QTB can select and use the same USB audio device, and encode at different 
rates. You can also connect different USB audio devices, through a Griffin powered USB Audio 
hub, different copies of QTB will recognize and utilize different devices. If you are only interested 
in narration, Telex and Plantrontics make some nice noise-canceling USB digital headset mics, 
which QTB recognizes. 

 
Create custom graphics to display with your audio stream. 
 

1. Download qttreamsplicer from  
  http://developer.apple.com/samplecode/QuickTime/idxStreaming-date.html 
  Select the Mac or Windows version. 

2. Make a graphic with Photoshop, with the dimensions even multiples of 16, at 72 dpi. Flatten and 
save as a tiff. 

3. Open qtstreamsplicer, go to Splice>Splice Image Over Stream. 
4. Select your tiff image, then select your audio-only reference movie. 
5. Select “Make Movie Self-Contained” and enter the tiff’s dimensions, then click “Splice!” 
6. Gime the movie a new name and save it. Open the new movie in QT Player Pro, you should see 

the graphic. Click on the play button, you should hear your audio stream. In Movie>Get Movie 
Properties, enable Auto-Play, and save. Close the movie. 

7. Click on the movie to test that it opens, and auto-plays your audio stream. Use this new reference 
movie for your web page, replacing the old one. Change the html code to reflect the name 
change of the reference movie. 

 
Other Sources of Information 
 

1. Lots of good stuff and more advanced techniques at http://soundscreen.com/ 
2. QuickTime Streaming Server Users list 
  http://lists.apple.com/mailman/listinfo/streaming-server-users 


